$re = '/(?!(<IMG.+src=\"))http:\/\/i[0-9]{3}\.photobucket\.com\/albums\/[^\/]+\/[^\/]+\/[^\/\"]+(?=\".*/>)/m';
$str = '<img src="http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" />
<IMG src="http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" foo="bar"/>
<img alt="text" src="http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" />
<img alt="text" src="http://i077.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);