use strict;
my $str = '<img src="http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" />
<IMG src="http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" foo="bar"/>
<img alt="text" src="http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" />
<img alt="text" src="http://i077.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" />';
my $regex = qr/(?!(<IMG.+src=\"))http:\/\/i[0-9]{3}\.photobucket\.com\/albums\/[^\/]+\/[^\/]+\/[^\/\"]+(?=\".*/>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}