re = /(?!(<IMG.+src=\"))http:\/\/i[0-9]{3}\.photobucket\.com\/albums\/[^\/]+\/[^\/]+\/[^\/\"]+(?=\".*\/>)/m
str = '<img src="http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" />
<IMG src="http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" foo="bar"/>
<img alt="text" src="http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" />
<img alt="text" src="http://i077.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end