import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!(<IMG.+src=\\\"))http:\\/\\/i[0-9]{3}\\.photobucket\\.com\\/albums\\/[^\\/]+\\/[^\\/]+\\/[^\\/\\\"]+(?=\\\".*/>)";
final String string = "<img src=\"http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg\" />\n"
+ "<IMG src=\"http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg\" foo=\"bar\"/>\n"
+ "<img alt=\"text\" src=\"http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg\" />\n"
+ "<img alt=\"text\" src=\"http://i077.photobucket.com/albums/myalbum/Emi998/mypicture.jpg\" />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}