# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(\d+-)((?:\d+~\d+|(?:,?\s*\d+){2,})+)(?=,\s*\d+-|\"))/\1(\2)/gm;t' <<< "sample_string1 = \"376-12~23, 28, 32, 35, 37,376-1\"
sample_string2 = \"391-1~8, 391-22~23\"
sample_string3 = \"391-10~21, 391-24, 27, 29\""