# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(\d+-)((?:\d+~\d+|(?:,?\s*\d+){2,})+)(?=,\s*\d+-|\"))"
test_str = ("sample_string1 = \"376-12~23, 28, 32, 35, 37,376-1\"\n"
"sample_string2 = \"391-1~8, 391-22~23\"\n"
"sample_string3 = \"391-10~21, 391-24, 27, 29\"")
subst = "\\1(\\2)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.