#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(\d+-)((?:\d+~\d+|(?:,?\s*\d+){2,})+)(?=,\s*\d+-|\"))"
Local $sString = "sample_string1 = "376-12~23, 28, 32, 35, 37,376-1"" & @CRLF & _
"sample_string2 = "391-1~8, 391-22~23"" & @CRLF & _
"sample_string3 = "391-10~21, 391-24, 27, 29""
Local $sSubst = "\1(\2)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)