$re = '/(?:(\d+-)((?:\d+~\d+|(?:,?\s*\d+){2,})+)(?=,\s*\d+-|\"))/m';
$str = 'sample_string1 = "376-12~23, 28, 32, 35, 37,376-1"
sample_string2 = "391-1~8, 391-22~23"
sample_string3 = "391-10~21, 391-24, 27, 29"';
$subst = "\1(\2)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;