const regex = new RegExp('(?:(\\d+-)((?:\\d+~\\d+|(?:,?\\s*\\d+){2,})+)(?=,\\s*\\d+-|\\"))', 'gm')
const str = `sample_string1 = "376-12~23, 28, 32, 35, 37,376-1"
sample_string2 = "391-1~8, 391-22~23"
sample_string3 = "391-10~21, 391-24, 27, 29"`;
const subst = `\1(\2)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);