import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(\\d+-)((?:\\d+~\\d+|(?:,?\\s*\\d+){2,})+)(?=,\\s*\\d+-|\\\"))";
final String string = "sample_string1 = \"376-12~23, 28, 32, 35, 37,376-1\"\n"
+ "sample_string2 = \"391-1~8, 391-22~23\"\n"
+ "sample_string3 = \"391-10~21, 391-24, 27, 29\"";
final String subst = "\\1(\\2)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}