#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\[).*(?=\])"
Local $sString = "WAM: Hours" & @CRLF & _
"WAM 1: 9823732.2314324.00,(General Overhead): [9.0]" & @CRLF & _
"WAM 2: 9823732.2314324.00,(General Training): [5]" & @CRLF & _
"WAM 3: 9823732.2314324.00,(Project 3): [12]" & @CRLF & _
"WAM 4: 9823732.2314324.00,(Project 4): [17]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")