use strict;
my $str = 'WAM: Hours
WAM 1: 9823732.2314324.00,(General Overhead): [9.0]
WAM 2: 9823732.2314324.00,(General Training): [5]
WAM 3: 9823732.2314324.00,(Project 3): [12]
WAM 4: 9823732.2314324.00,(Project 4): [17]';
my $regex = qr/(?<=\[).*(?=\])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}