import Foundation
let pattern = #"(?<=\[).*(?=\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
WAM: Hours
WAM 1: 9823732.2314324.00,(General Overhead): [9.0]
WAM 2: 9823732.2314324.00,(General Training): [5]
WAM 3: 9823732.2314324.00,(Project 3): [12]
WAM 4: 9823732.2314324.00,(Project 4): [17]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)