using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\[).*(?=\])";
string input = @"WAM: Hours
WAM 1: 9823732.2314324.00,(General Overhead): [9.0]
WAM 2: 9823732.2314324.00,(General Training): [5]
WAM 3: 9823732.2314324.00,(Project 3): [12]
WAM 4: 9823732.2314324.00,(Project 4): [17]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}