import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\[).*(?=\\])";
final String string = "WAM: Hours\n"
+ "WAM 1: 9823732.2314324.00,(General Overhead): [9.0]\n"
+ "WAM 2: 9823732.2314324.00,(General Training): [5]\n"
+ "WAM 3: 9823732.2314324.00,(Project 3): [12]\n"
+ "WAM 4: 9823732.2314324.00,(Project 4): [17]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}