$re = '/(?<=\[).*(?=\])/m';
$str = 'WAM: Hours
WAM 1: 9823732.2314324.00,(General Overhead): [9.0]
WAM 2: 9823732.2314324.00,(General Training): [5]
WAM 3: 9823732.2314324.00,(Project 3): [12]
WAM 4: 9823732.2314324.00,(Project 4): [17]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);