#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{(([^{}]*|\{[^}]*\})+)\}"
Local $sString = "{remainingUsers, plural, =1 {# more agent} other {# more agents}}. Use the search to refine further." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Hello, Your friend {friend} is now online. {gender, select, female {She} male {He} other {They}} "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")