import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(([^\\{\\}]*|\\{[^\\}]*\\})+)\\}";
final String string = "{remainingUsers, plural, =1 {# more agent} other {# more agents}}. Use the search to refine further.\n\n\n"
+ "Hello, Your friend {friend} is now online. {gender, select, female {She} male {He} other {They}} ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}