using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{(([^{}]*|\{[^}]*\})+)\}";
string input = @"{remainingUsers, plural, =1 {# more agent} other {# more agents}}. Use the search to refine further.
Hello, Your friend {friend} is now online. {gender, select, female {She} male {He} other {They}} ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}