re = /\{(([^{}]*|\{[^}]*\})+)\}/
str = '{remainingUsers, plural, =1 {# more agent} other {# more agents}}. Use the search to refine further.
Hello, Your friend {friend} is now online. {gender, select, female {She} male {He} other {They}} '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end