// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\{(([^{}]*|\{[^}]*\})+)\}").unwrap();
let string = "{remainingUsers, plural, =1 {# more agent} other {# more agents}}. Use the search to refine further.
Hello, Your friend {friend} is now online. {gender, select, female {She} male {He} other {They}} ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}