package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{(([^{}]*|\{[^}]*\})+)\}`)
var str = `{remainingUsers, plural, =1 {# more agent} other {# more agents}}. Use the search to refine further.
Hello, Your friend {friend} is now online. {gender, select, female {She} male {He} other {They}} `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}