#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?<! [\d.] )" & @CRLF & _
"(?=" & @CRLF & _
" \d+ \. \d+ " & @CRLF & _
" (?! [\d.] )" & @CRLF & _
")" & @CRLF & _
"1 \.? 0 \.? 2 \.? 0 \.? 0" & @CRLF & _
"(?! [\d.] )" & @CRLF & _
""
Local $sString = "10200" & @CRLF & _
"1.0200" & @CRLF & _
"10.200" & @CRLF & _
"102.00" & @CRLF & _
"1020.0" & @CRLF & _
"" & @CRLF & _
".10200" & @CRLF & _
"1.02.00" & @CRLF & _
"10200." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")