using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<! [\d.] )
(?=
\d+ \. \d+
(?! [\d.] )
)
1 \.? 0 \.? 2 \.? 0 \.? 0
(?! [\d.] )
";
string input = @"10200
1.0200
10.200
102.00
1020.0
.10200
1.02.00
10200.
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}