const regex = new RegExp('(?<! [\\d.] )
(?=
\\d+ \\. \\d+
(?! [\\d.] )
)
1 \\.? 0 \\.? 2 \\.? 0 \\.? 0
(?! [\\d.] )
', 'g')
const str = `10200
1.0200
10.200
102.00
1020.0
.10200
1.02.00
10200.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}