$re = '/(?<! [\d.] )
(?=
\d+ \. \d+
(?! [\d.] )
)
1 \.? 0 \.? 2 \.? 0 \.? 0
(?! [\d.] )
/x';
$str = '10200
1.0200
10.200
102.00
1020.0
.10200
1.02.00
10200.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);