import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<! [\\d.] )\n"
+ "(?=\n"
+ " \\d+ \\. \\d+ \n"
+ " (?! [\\d.] )\n"
+ ")\n"
+ "1 \\.? 0 \\.? 2 \\.? 0 \\.? 0\n"
+ "(?! [\\d.] )\n";
final String string = "10200\n"
+ "1.0200\n"
+ "10.200\n"
+ "102.00\n"
+ "1020.0\n\n"
+ ".10200\n"
+ "1.02.00\n"
+ "10200.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}