import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w\\.)(\\s\\w+\\sJ?r?\\.?)*(\\w+[\\sI\\,\\sJSr.]{0,5})$";
final String string = "H. Graham Motion\n"
+ "T. James Kelly\n"
+ "J. Palacios Moli\n"
+ "A. Chadwick Box\n"
+ "H. Graham Motion III\n"
+ "T. James Kelly, Jr.\n"
+ "H. Graham Motion II\n"
+ "V. Barboza Jr.";
final String subst = "\\1 \\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}