const regex = /^(\w\.)(\s\w+\sJ?r?\.?)*(\w+[\sI\,\sJSr.]{0,5})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w\\.)(\\s\\w+\\sJ?r?\\.?)*(\\w+[\\sI\\,\\sJSr.]{0,5})$', 'gm')
const str = `H. Graham Motion
T. James Kelly
J. Palacios Moli
A. Chadwick Box
H. Graham Motion III
T. James Kelly, Jr.
H. Graham Motion II
V. Barboza Jr.`;
const subst = `\1 \3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);