$re = '/^(\w\.)(\s\w+\sJ?r?\.?)*(\w+[\sI\,\sJSr.]{0,5})$/m';
$str = 'H. Graham Motion
T. James Kelly
J. Palacios Moli
A. Chadwick Box
H. Graham Motion III
T. James Kelly, Jr.
H. Graham Motion II
V. Barboza Jr.';
$subst = "\1 \3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;