import re
regex = re.compile(r"^(\w\.)(\s\w+\sJ?r?\.?)*(\w+[\sI\,\sJSr.]{0,5})$", flags=re.MULTILINE)
test_str = ("H. Graham Motion\n"
"T. James Kelly\n"
"J. Palacios Moli\n"
"A. Chadwick Box\n"
"H. Graham Motion III\n"
"T. James Kelly, Jr.\n"
"H. Graham Motion II\n"
"V. Barboza Jr.")
subst = "\\1 \\3"
result = regex.sub(subst, test_str)
if result:
print(result)