use strict;
my $str = 'H. Graham Motion
T. James Kelly
J. Palacios Moli
A. Chadwick Box
H. Graham Motion III
T. James Kelly, Jr.
H. Graham Motion II
V. Barboza Jr.';
my $regex = qr/^(\w\.)(\s\w+\sJ?r?\.?)*(\w+[\sI\,\sJSr.]{0,5})$/mp;
my $subst = '\\1 \\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";