#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\+[0-9]*)\s(\([0-9]*\)\s[0-9]{3}\s[0-9]{2}-[0-9]{2})"
Local $sString = "+90 (555) 555 55-55" & @CRLF & _
"+190 (555) 555 55-55" & @CRLF & _
"+1 (555) 555 55-55"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")