// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\+[0-9]*)\s(\([0-9]*\)\s[0-9]{3}\s[0-9]{2}-[0-9]{2})").unwrap();
let string = "+90 (555) 555 55-55
+190 (555) 555 55-55
+1 (555) 555 55-55";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}