use strict;
my $str = '+90 (555) 555 55-55
+190 (555) 555 55-55
+1 (555) 555 55-55';
my $regex = qr`(\+[0-9]*)\s(\([0-9]*\)\s[0-9]{3}\s[0-9]{2}-[0-9]{2})`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}