$re = '`(\+[0-9]*)\s(\([0-9]*\)\s[0-9]{3}\s[0-9]{2}-[0-9]{2})`m';
$str = '+90 (555) 555 55-55
+190 (555) 555 55-55
+1 (555) 555 55-55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);