re = /(\+[0-9]*)\s(\([0-9]*\)\s[0-9]{3}\s[0-9]{2}-[0-9]{2})/m
str = '+90 (555) 555 55-55
+190 (555) 555 55-55
+1 (555) 555 55-55'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end