package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^][]*](*SKIP)(*F)|(?:https?://)?(?:www\.)?[\w@:%.+~#=]{2,256}\.[a-z]{2,6}\b[\w-@:%+.~#?&/=]*`)
var str = `www.example.com
http://example.com.nz
example.com
http://www.example.com?2rjl6
example.com/first/second
https://example.us.edi?34535/534534?dfg=g&fg
etc...
I want no match if any of the above URLs are enclosed in square brackets [ ] like this:
[www.example.com]
[http://example.com.nz]
etc...
.aaaa
e.g.
Lorem ipsum dolor sit amet, consectetur [http://example.com.nz] llamcorper et lacus. Morbi sodales convallis lectus a efficitur: example.com/first/second vitae nisl placerat.
Fusce non ipsum a augue http://example.com.nz http://www.example.com?2rjl6 aculis augue. Nullam eu nulla lectus.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}