import re
regex = re.compile(r"\[[^][]*](*SKIP)(*F)|(?:https?://)?(?:www\.)?[\w@:%.+~#=]{2,256}\.[a-z]{2,6}\b[\w-@:%+.~#?&/=]*", flags=re.MULTILINE)
test_str = ("www.example.com \n"
"http://example.com.nz \n"
"example.com\n"
"http://www.example.com?2rjl6\n"
"example.com/first/second\n"
"https://example.us.edi?34535/534534?dfg=g&fg\n\n"
"etc...\n"
"I want no match if any of the above URLs are enclosed in square brackets [ ] like this:\n\n"
"[www.example.com]\n"
"[http://example.com.nz]\n"
"etc...\n\n"
".aaaa\n\n"
"e.g.\n\n"
"Lorem ipsum dolor sit amet, consectetur [http://example.com.nz] llamcorper et lacus. Morbi sodales convallis lectus a efficitur: example.com/first/second vitae nisl placerat.\n\n"
"Fusce non ipsum a augue http://example.com.nz http://www.example.com?2rjl6 aculis augue. Nullam eu nulla lectus.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")