#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?(DEFINE)" & @CRLF & _
" (?<token>What\sis|plus|minus|multiplied\sby|divided\sby)" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"^\g<token>(?:\s+\g<token>)*$"
Local $sString = "What is plus divided by" & @CRLF & _
"" & @CRLF & _
"What is 5 plus 2 divided by 4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")