import re
regex = re.compile(r"""
(?(DEFINE)
(?<token>What\sis|plus|minus|multiplied\sby|divided\sby)
)
^\g<token>(?:\s+\g<token>)*$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("What is plus divided by\n\n"
"What is 5 plus 2 divided by 4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")