package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?(DEFINE)
(?<token>What\sis|plus|minus|multiplied\sby|divided\sby)
)
^\g<token>(?:\s+\g<token>)*$`)
var str = `What is plus divided by
What is 5 plus 2 divided by 4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}