const regex = /(?(DEFINE)
(?<token>What\sis|plus|minus|multiplied\sby|divided\sby)
)
^\g<token>(?:\s+\g<token>)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?<token>What\\sis|plus|minus|multiplied\\sby|divided\\sby)
)
^\\g<token>(?:\\s+\\g<token>)*$', 'gm')
const str = `What is plus divided by
What is 5 plus 2 divided by 4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}