using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(The\s)?(cat\s)?(sat\s)?(on\s)?(the\s)?(mat\.)?";
string input = @"The cat sat on the mat.
The cat sat on the mat
The cat sat on teh mat.
The kat sat on the mat.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}