import re
regex = re.compile(r"^(The\s)?(cat\s)?(sat\s)?(on\s)?(the\s)?(mat\.)?", flags=re.MULTILINE)
test_str = ("The cat sat on the mat.\n"
"The cat sat on the mat\n"
"The cat sat on teh mat.\n"
"The kat sat on the mat.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")