$re = '/^(The\s)?(cat\s)?(sat\s)?(on\s)?(the\s)?(mat\.)?/m';
$str = 'The cat sat on the mat.
The cat sat on the mat
The cat sat on teh mat.
The kat sat on the mat.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);