import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(The\\s)?(cat\\s)?(sat\\s)?(on\\s)?(the\\s)?(mat\\.)?";
final String string = "The cat sat on the mat.\n"
+ "The cat sat on the mat\n"
+ "The cat sat on teh mat.\n"
+ "The kat sat on the mat.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}