# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d)DEC(?=[A-Z])/ $0 /gm;t' <<< "START1SEP2 1DECX JANEND"