import Foundation
let pattern = #"(?<=\d)DEC(?=[A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"START1SEP2 1DECX JANEND"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" $0 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)