use strict;
my $str = 'START1SEP2 1DECX JANEND';
my $regex = qr/(?<=\d)DEC(?=[A-Z])/mp;
my $subst = ' $0 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";